WordPress Version 2.7 aktiv

0
589

Wieder einmal ist es geschafft. Heute Morgen habe ich mich darum gekümmert, die neueste Version von WordPress zu installieren. Wie immer ging dies eigentlich recht reibungslos. Per FTP die Dateien vom Server gesichert. Einen Export in WordPress durchgeführt und zur Sicherheit auch nochmals die Datenbank gesichert. Schliesslich habe ich noch alle Plugins definiert und dann alle Dateien vom Server gelöscht (natürlich bis auf die config-Datei und das content Verzeichnis). Anschliessend wieder die neuen Dateien hochgeladen, die upgrade Seite aufgerufen und wieder alle Plugins aktiviert.

Beim Lesen der Upgrade Hinweise (sollte man eigentlich immer machen) ist mir dann allerdings aufgefallen, dass es ab Version 2.5 einige Sicherheitsschlüssel gab, die es in der config-Datei zu definieren galt. Dieser Hinweis ist mir bei meinem letzten Upgrade scheinbar entgangen. Also wurden die entsprechenden Definitionen nachgetragen. Weiterhin ist mir aufgefallen, dass in der config noch zwei Datenbankdefinitionen vorhanden sind, die es in meiner config-Datei auch nicht gab. Beide habe ich ergänzt (collate und utf Einstellung).

Beim ersten Aufruf der Seite bekam ich dann doch einen Fehler. Meine Umlaute waren dahin. Das mit der utf-8 Einstellung für die Datenbank in der config Datei war wohl etwas verfrüht. Ich habe die Definition zunächst wieder entfernt und alles läuft einwandfrei. Ich denke ich muß in der Datenbank den Zeichensatz auch ändern, damit ich dies in der config nachziehen kann. Hierum werde ich mich später einmal kümmern.

Beim aktivieren der Plugins habe ich dann direkt auch noch sämtliche Plugins aktualisiert, von denem mir eine neue Version angezeigt wurde. Auch dies funktionierte problemlos. Nur mit den „Stats“ hatte ich zunächst etwas Probleme. Das Plugin wollte mein API Key haben. Ich kann mich gar nicht erinnern, dass ich den nach jedem Upgrade neu eingegeben habe. Die Frage war nun zunächst, wo bekomme ich den her ? Ein erster Blick in meinen Password Safe zeigte mir, dass ich den Key dort nicht hinterlegt habe (wofür habe ich das Programm denn eigentlich, wenn ich es nicht nutze ?!). Dann viel mir ein, dass ich mich eigentlich nur bei WordPress einloggen muss. Den Key habe ich allerdings nicht gefunden. Nach einer verzweifelten Suche in den Support Hinweisen habe ich dann noch mehrmals mein Profil durchsucht. Der Key musste hier irgendwo sein.

Schließlich habe ich ihn ganz oben gefunden. Die Info ist neben den übrigen Infos zum Profil so unscheinbar dargestellt, dass ich den Key wohl jedesmal überlesen hatte. So nun dachte ich, ich trage den Key ein und alles ist fertig. Ganz so einfach war es dann doch nicht. Das Plugin meinte, dass dieser Key für einen Blog benutzt wird. In der Tat, dachte ich. Für meinen Blog. Tatsächlich musste man ein „replace“ vornehmen und schon funktioniert wieder alles.

In den nächsten Tagen werde ich dann den Blog etwas ausgiebiger Testen. Auch das verwendete Template habe ich beim Ersteller noch nicht auf mögliche Erweiterungen hin überprüft. Bis dahin freue ich mich natürlich auch über Hinweise, wenn irgendetwas nicht funktioniert.

Ach ja, hatte ich fast vergessen. Mann darf sich natürlich auch mal wieder über eine neue Anordnung des Dashboards und der Anordnung der Navigationssteuerung freuen.

Kommentieren Sie den Artikel